$re = '/[a-zñÑ\-\_0-9áéíóúÁÉÍÓÚ]{3,20}/i';
$str = '1234';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);