re = /^<(?:"[^"]*"|[^>])+>/mi
str = '<html attribute1="<test1>" test2 attribute2="test2"></html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end