# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d)(%)/$1\\$2/gm;t' <<< "This is 55% of the total.
% a comment
"