const regex = /(\d)(%)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d)(%)', 'gm')
const str = `This is 55% of the total.
% a comment
`;
const subst = `$1\\$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);