using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?) contains (.*?)\s*(?:([|&])\3|$)\s*";
string input = @"huile contains rgbgrbrb9gr && huile contains fcecec
oil & other contains oil & blah
huile contains test2 || huile contains test4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}