const regex = /(.*?) contains (.*?)\s*(?:([|&])\3|$)\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?) contains (.*?)\\s*(?:([|&])\\3|$)\\s*', 'gm')
const str = `huile contains rgbgrbrb9gr && huile contains fcecec
oil & other contains oil & blah
huile contains test2 || huile contains test4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}