$re = '/(.*?) contains (.*?)\s*(?:([|&])\3|$)\s*/m';
$str = 'huile contains rgbgrbrb9gr && huile contains fcecec
oil & other contains oil & blah
huile contains test2 || huile contains test4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);