package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-2][0-9]|(3)[0-1])(\/)(((0)[0-9])|((1)[0-2]))$`)
var str = `31/12
30/12
01/01
a01/02
01/01basdasd
32/01
32/12
01/13
32/13
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}