package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(->)`)
var str = `error->400
error->debug->warning`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}