using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""(https?.+?\.(jpe?g|gif|png))\""";
string input = @"<a href=""https://website.com/wp-content/uploads/2018/09/image-image.image.jpg""><img class=""alignnone size-medium wp-image-11275"" src=""https://website.com/wp-content/uploads/2018/09/image-image.image-300x200.jpg"" alt="" width=""300"" height=""200"" /></a> <a href=""https://kids-at-home.ch/wp-content/uploads/2018/09/image2-image2-image2.jpg""><img class=""alignnone size-medium wp-image-11271"" src=""https://kids-at-home.ch/wp-content/uploads/2018/09/image2-image2-image2.jpg-300x200.jpg"" alt="" width=""300"" height=""200"" />
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}