$re = '/\.?0+$/m';
$str = '1.7500
1.1010
1.0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);