$re = '/(?i)(?=.*\bLorem\b).*(?=.*\btext\b).*(?=.*\bdummy\b).*/m';
$str = 'Ipsum is simply dummy text of the printing and typesetting industry.
Lorem Ipsum has been the industry\'s standard dummy text ever since the';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);