package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mU)(.+),`)
var str = `IPswitch-E-WiFi,csv,m2-0Ja,___EV_IB,0000,0001, 937456,0000000006, 0,0002169122, 0,0002169121, 0,0002169121, 0,0002169121, 0,0002169121, 0,0002169121, 0,0002169121,00,00,00,00,00,00,00,00,00,00,00000,2A61 ,243`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}