import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\b((?:https?://|www\\d{0,3}[.]|[a-z0-9.\\-]+[.][a-z]{2,4}/)(?:[^\\s()<>'\",]+|\\(([^\\s()<>'\",]+|(\\([^\\s()<>'\",]+\\)))*\\))+(?:\\(([^\\s()<>'\",]+|(\\([^\\s()<>'\",]+\\)))*\\)|[^\\s`!()\\[\\]\\{\\};:'\".,<>?«»“â€â€˜â€™]))";
final String string = "www.google.com(','dccccc)asx asx asx http://google/com,asd";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}