// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:[a-z]+[a-z89]+[a-z]+|[a-z]+)[9]?").unwrap();
let string = "aaa898a8 a8a8a8a8 9aaaa9a9 8aaaa8a89";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}