$re = '/(<[^>]*>|&[^;]*;)(*SKIP)(*FAIL)|(<)?(\bmicro)/m';
$str = '<micro';
$subst = "$2µ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;