import Foundation
let pattern = #"(<[^>]*>|&[^;]*;)(*SKIP)(*FAIL)|(<)?(\bmicro)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<micro"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2µ"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)