use strict;
my $str = '
<div class="header-info-box">
Разный контент, <span> включая теги</span>
<div>
<div> </div>
</div>
</div>
';
my $regex = qr~<div class="header-info-box">\K((?:[^<]|(?!</?div).|<div(?1)</div>)*+)~mp;
my $subst = '<div class="hello"></div>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";