$re = '~.*?([^/]+)/[^/]+$~m';
$str = 'https://example.com/names/ani/digitalcod-org
https://example.com/names/bmc/ambulancecod.org';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);