use strict;
my $str = '1.2.3 (1.234*xY)';
my $regex = qr/^[^(]*\(([^*]+)\*.*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";