re = /^(movie|tv)\s*(.*?)(?:\s+season)?(?:\s+([0-9]+(?:\s+[0-9]+)*))?$/m
str = 'tv game of thrones season 1 2 3
movie inception'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end