re = /^\s*(\d\d)\:(\d\d)\s*$/m
str = '1985.10.25 11:30
1985-10-25 11:30
11:30
11:30
11:30
11:30
11:30
11:30 1985.10.25
aa:bb
11:bb
aa:22
a1:22
1a:22
1a:3a
1a:a3
111:30
1:2
1:20
01:2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end