import Foundation
let pattern = #"^\s*(\d\d)\:(\d\d)\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1985.10.25 11:30
1985-10-25 11:30
11:30
11:30
11:30
11:30
11:30
11:30 1985.10.25
aa:bb
11:bb
aa:22
a1:22
1a:22
1a:3a
1a:a3
111:30
1:2
1:20
01:2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)