using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<li>(.*?)<\/li>";
string input = @"<ul><li>Чебурашка</li><li>Крокодил Гена</li><li>Шапокляк</li></ul>";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}