$re = '/<li>(.*?)<\/li>/s';
$str = '<ul><li>Чебурашка</li><li>Крокодил Гена</li><li>Шапокляк</li></ul>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);