re = /(?i)quote\s*(\d+)/m
str = 'sjhsh QUOTE 234566
sdsds customer call QUote 239876 Call back
adsdfh unknown call from customer QUOTE 189067 sdkjsd woieweio
QUOTE 657894 customer called for service
QUOTE 657894 customer called for service QUOTE 657894 customer called for service
No qte'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end