import Foundation
let pattern = #"(?i)quote\s*(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
sjhsh QUOTE 234566
sdsds customer call QUote 239876 Call back
adsdfh unknown call from customer QUOTE 189067 sdkjsd woieweio
QUOTE 657894 customer called for service
QUOTE 657894 customer called for service QUOTE 657894 customer called for service
No qte
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)