$re = '/<i class="(?:.*\s)?([^"]*)"><\/i>/m';
$str = 'function myFunction() {
var str = \'<i class="fa fa-edit"></i>\';
var res = str.match(/\'fa-\'*/);
return res;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);