const regex = /^(?!=.*[_.:;\-\\\/@+*]{2})(?=[^\d\n]*\d)[\w_.:;\-\\\/@+*]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!=.*[_.:;\\-\\\\\\\/@+*]{2})(?=[^\\d\\n]*\\d)[\\w_.:;\\-\\\\\\\/@+*]+$', 'gm')
const str = `ajh12-&
671%&i^
165271
agya678
yah@123
kj*12-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}