Group year(?<year>[\d]{4}) {4}matches exactly 4 characters from the set below:
\da digit
-the literal - (4510 / 558 / 2D16)
Group month(?<month>0[1-9]|1[1-2]) 0the literal 0 (4810 / 608 / 3016)
1-9one character from 1 (4910) to 9 (5710)
1the literal 1 (4910 / 618 / 3116)
1-2one character from 1 (4910) to 2 (5010)
-the literal - (4510 / 558 / 2D16)
Group day(?<day>0[1-9]|[1-2][0-9]|3[0-1]) 0the literal 0 (4810 / 608 / 3016)
1-9one character from 1 (4910) to 9 (5710)
2nd Alternative[1-2][0-9] 1-2one character from 1 (4910) to 2 (5010)
0-9one character from 0 (4810) to 9 (5710)
3the literal 3 (5110 / 638 / 3316)
0-1one character from 0 (4810) to 1 (4910)
Tthe literal T (8410 / 1248 / 5416) (case insensitive)
Group hour(?<hour>[0-1][0-9]|2[0-3]) 1st Alternative[0-1][0-9] 0-1one character from 0 (4810) to 1 (4910)
0-9one character from 0 (4810) to 9 (5710)
2the literal 2 (5010 / 628 / 3216)
0-3one character from 0 (4810) to 3 (5110)
:the literal : (5810 / 728 / 3A16)
Group minute(?<minute>[0-5][0-9]) 0-5one character from 0 (4810) to 5 (5310)
0-9one character from 0 (4810) to 9 (5710)
:the literal : (5810 / 728 / 3A16)
Group second(?<second>[0-5][0-9]) Non-Capturing Group(?:Z|.(?<millisecond>[0-9]{2,3})) g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string
i modifier: insensitive. Matches without distinguishing uppercase and lowercase letters