$re = '/<Field(?:Array)?(?=(?:[^>"\']|"[^"]*"|\'[^\']*\')*?\sname\s*=\s*(?:([\'"])\s*document\s*\1))\s+(?:"[\S\s]*?"|\'[\S\s]*?\'|[^>]*?)+\/>/';
$str = ' <Field
name="amount"
component={FormField}
label={t(\'form.amount\')}
/>
<Field
name="datereception"
component={FormField}
label={t(\'form.datereception\')}
/>
<Field
component={FormField}
name="document"
typeInput="selectAutocomplete"
/>
<Field
name="datedeferred"
component={FormField}
label={t(\'form.datedeferred\')}
/>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);