# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<Field(?:Array)?(?=(?:[^>\"']|\"[^\"]*\"|'[^']*')*?\sname\s*=\s*(?:(['\"])\s*document\s*\1))\s+(?:\"[\S\s]*?\"|'[\S\s]*?'|[^>]*?)+\/>"
test_str = (" <Field\n"
" name=\"amount\"\n"
" component={FormField}\n"
" label={t('form.amount')}\n"
" />\n"
" <Field\n"
" name=\"datereception\"\n"
" component={FormField}\n"
" label={t('form.datereception')}\n"
" />\n"
" <Field\n"
" component={FormField}\n"
" name=\"document\"\n"
" typeInput=\"selectAutocomplete\"\n"
" />\n"
" <Field\n"
" name=\"datedeferred\"\n"
" component={FormField}\n"
" label={t('form.datedeferred')}\n"
" />")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.