hthe literal h (10410 / 1508 / 6816) (case sensitive)
.any character (except for line terminators)
.any character (except for line terminators)
pthe literal p (11210 / 1608 / 7016) (case sensitive)
s?optionally matches the literal s (11510 / 1638 / 7316) (case sensitive)