#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ",(?=(?:[^""]*""[^""]*"")*(?![^""]*""))"
Local $sString = "CANADIAN PACIFIC HOTELS B.V.;Branch / Legal Entity;A0060201;24153390;NL001463743B01;Joan Muyskenweg 10;1096;CJ Amsterdam;NL;00602.S0010;130_CE_CANADIAN PACIFIC HOTELS INTERN dfgdsgg" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")