#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(([(_)a-zA-Z0-9\.\-]{1,})(@)([a-zA-Z0-9\-]+)(\.)([a-zA-Z]{2,3})((\.)([a-z]{2,3}))?)"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
""jj.jj@domain.com"" & @CRLF & _
""hello@myemailadd.com.uk "" & @CRLF & _
""HELLO@MYNAME.COM"" & @CRLF & _
""japan@water.com.uk.uk.uk"" & @CRLF & _
""me.me.me@domain.com.uk.uk"" & @CRLF & _
""hello99@khalsa-aid.com"" & @CRLF & _
""hello.me@myemailadd.com.in"" & @CRLF & _
""hello.me@tax.gov.uk" " & @CRLF & _
""my_name@council.co.uk" " & @CRLF & _
"" & @CRLF & _
""my-hello@bye-bye.co.uk"" & @CRLF & _
""hello@my-99GOALS.co9.uk"" & @CRLF & _
"" & @CRLF & _
""Hello_Hello@two.com"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")