const regex = /(([(_)a-zA-Z0-9\.\-]{1,})(@)([a-zA-Z0-9\-]+)(\.)([a-zA-Z]{2,3})((\.)([a-z]{2,3}))?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([(_)a-zA-Z0-9\\.\\-]{1,})(@)([a-zA-Z0-9\\-]+)(\\.)([a-zA-Z]{2,3})((\\.)([a-z]{2,3}))?)', 'gm')
const str = `
"jj.jj@domain.com"
"hello@myemailadd.com.uk "
"HELLO@MYNAME.COM"
"japan@water.com.uk.uk.uk"
"me.me.me@domain.com.uk.uk"
"hello99@khalsa-aid.com"
"hello.me@myemailadd.com.in"
"hello.me@tax.gov.uk"
"my_name@council.co.uk"
"my-hello@bye-bye.co.uk"
"hello@my-99GOALS.co9.uk"
"Hello_Hello@two.com"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}