using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d.*)\d(?: *\d *){13,14}\d(?! *\d)";
string input = @"Test
""CC# 123456789012345"",
""Credit Card 123456 7890 123456"",
""Text 1234 5678 9012 3456 Text"",
""Something 123 456 789 012 3456"",
""Not a card (too long): 12345689123456789123"",
""Just a value 123"",";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}