import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\[\\[).*(?=\\]\\])";
final String string = ": [[Bertus Aafjes]] (1914–1993), NL\n"
+ ": [[Jeppe Aakjær]] (1866–1930), DK\n"
+ ": [[Johannes Aal]] (um 1500–1551), CH\n"
+ ": [[Hans Aanrud]] (1863–1953), NO\n"
+ ": [[Emil Aarestrup]] (1800–1856), DK\n"
+ ": [[Soazig Aaron]] (* 1949), FR\n"
+ ": [[Ivar Aasen]] (1813–1896), NO";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}