# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\[\[).*(?=\]\])"
test_str = (": [[Bertus Aafjes]] (1914–1993), NL\n"
": [[Jeppe Aakjær]] (1866–1930), DK\n"
": [[Johannes Aal]] (um 1500–1551), CH\n"
": [[Hans Aanrud]] (1863–1953), NO\n"
": [[Emil Aarestrup]] (1800–1856), DK\n"
": [[Soazig Aaron]] (* 1949), FR\n"
": [[Ivar Aasen]] (1813–1896), NO")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.