#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?i)\[\[(?<firstlevelfolder>(?:assets|Bücher|Dokument|epsilon_notes|kontakte|literatur|Projekt|Test|Wissen|WV)(?:[\w_]*)\/)(?<bildpfad>[^\|\\\]]+)(\\\||\|)*(?<bildattribut>[^\]]*)\]\]"
Local $sString = "Link zum Bild:" & @CRLF & _
"![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg]]" & @CRLF & _
"![[assets/(15) Bigger Arms Workout (Dumbbells Only) - YouTube - 3 34.jpeg]]" & @CRLF & _
"" & @CRLF & _
"![[subfolder/image.png|100x100]]" & @CRLF & _
"![[subfolder/sub2/image.png|100x100]]" & @CRLF & _
"![[../../ima/ge.png|100x100]]" & @CRLF & _
"[[Dokumente/Gesundheit/Dave/_Dave_overview]]" & @CRLF & _
"![[Projekte/image.png|100x100]]" & @CRLF & _
"![[Projekte_irgendwas/image.Png|100x100]]" & @CRLF & _
" " & @CRLF & _
"[[assets/MiSZ 2T.pdf]]" & @CRLF & _
"[[assets2/MiSZ 2T.pdf]]" & @CRLF & _
"![[Projekte/Mikroskop/Leica, Wild/Product Guide for Stereomicroscopes. Living up to Life.pdf]]" & @CRLF & _
"![[BA_GSZ 2_GSZ 2T.pdf#page=7]]" & @CRLF & _
"![[BA_GSZ 2_GSZ 2T.pdf]]" & @CRLF & _
"" & @CRLF & _
"Beispiel-tabelle:" & @CRLF & _
"Caption1 | Caption2 |" & @CRLF & _
"---|---|" & @CRLF & _
"Content1 text | Link innerhalb Tabelle mit Attributen" & @CRLF & _
"![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg\|300]] |" & @CRLF & _
"vorerst letzte Zeile | Text Text Text |" & @CRLF & _
"" & @CRLF & _
"![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg\|200]]"
Local $sSubst = "[<span style="color:blue">CPLinkToFile: </span> <span style="background-color: #caecff; color:blue">**${firstlevelfolder}${bildpfad}**</span>](/storage/emulated/0/onedrive/obsidian/${firstlevelfolder}${bildpfad})"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)