Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?i)\[\[(?<firstlevelfolder>(?:assets|Bücher|Dokument|epsilon_notes|kontakte|literatur|Projekt|Test|Wissen|WV)(?:[\w_]*)\/)(?<bildpfad>[^\|\\\]]+)(\\\||\|)*(?<bildattribut>[^\]]*)\]\]
/
gm
Input 1
1
New
Link zum Bild: ![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg]] ![[assets/(15) Bigger Arms Workout (Dumbbells Only) - YouTube - 3 34.jpeg]] ![[subfolder/image.png|100x100]] ![[subfolder/sub2/image.png|100x100]] ![[../../ima/ge.png|100x100]] [[Dokumente/Gesundheit/Dave/_Dave_overview]] ![[Projekte/image.png|100x100]] ![[Projekte_irgendwas/image.Png|100x100]] [[assets/MiSZ 2T.pdf]] [[assets2/MiSZ 2T.pdf]] ![[Projekte/Mikroskop/Leica, Wild/Product Guide for Stereomicroscopes. Living up to Life.pdf]] ![[BA_GSZ 2_GSZ 2T.pdf#page=7]] ![[BA_GSZ 2_GSZ 2T.pdf]] Beispiel-tabelle: Caption1 | Caption2 | ---|---| Content1 text | Link innerhalb Tabelle mit Attributen ![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg\|300]] | vorerst letzte Zeile | Text Text Text | ![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg\|200]]
Substitution
[<span style="color:blue">CPLinkToFile: </span> <span style="background-color: #caecff; color:blue">**${firstlevelfolder}${bildpfad}**</span>](/storage/emulated/0/onedrive/obsidian/${firstlevelfolder}${bildpfad})
Link zum Bild: ![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg]] ![[assets/(15) Bigger Arms Workout (Dumbbells Only) - YouTube - 3 34.jpeg]] ![[subfolder/image.png|100x100]] ![[subfolder/sub2/image.png|100x100]] ![[../../ima/ge.png|100x100]] [[Dokumente/Gesundheit/Dave/_Dave_overview]] ![[Projekte/image.png|100x100]] ![[Projekte_irgendwas/image.Png|100x100]] [[assets/MiSZ 2T.pdf]] [[assets2/MiSZ 2T.pdf]] ![[Projekte/Mikroskop/Leica, Wild/Product Guide for Stereomicroscopes. Living up to Life.pdf]] ![[BA_GSZ 2_GSZ 2T.pdf#page=7]] ![[BA_GSZ 2_GSZ 2T.pdf]] Beispiel-tabelle: Caption1 | Caption2 | ---|---| Content1 text | Link innerhalb Tabelle mit Attributen ![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg\|300]] | vorerst letzte Zeile | Text Text Text | ![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg\|200]]