$re = '/\|[pP]ublication\s*[Dd]ate=\s*[^\|}\n]+\s*[\|}]/m';
$str = 'Pass:
{{Design Pattern
|Title=test
|Publication Date=2021<hier-moet-iets-staan>
}}
Fail:
{{Design Pattern
|Title=test
}}
Pass:
{{Design Pattern
|Title=test
|Publication Date=
2021-32-154
|test=test
}}
Fail:
{{Design Pattern
|Title=test
|Publication Date=
}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);