package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Za-z0-9]{11}`)
var str = `https://www.youtube.com/watch?v=SEkUienM2oY&t=1265s
https://m.youtube.com/watch?v=SEkUienM2oY&t=1265s
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}