# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*HbbTV\/1\.4\.1(\s|\t)\((.*);(\s|\t)(.*);(\s|\t)(.*);(\s|\t)(.*);(\s|\t)(.*);\)"
test_str = "Mozilla/5.0 (DirectFB; Linux armv7l) AppleWebKit/537.6+ (KHTML, like Gecko) Safari/537.6+ HbbTV/1.4.1 (;TCL; ; ; ; ;)"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.