import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+\\.)?(\\d{3})+(?=\\S+)";
final String string = "12345678\n"
+ "87654321\n\n"
+ "3.123456\n"
+ "123456.3";
final String subst = "$1$2,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}