const regex = /^(\d+\.)?(\d{3})+(?=\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+\\.)?(\\d{3})+(?=\\S+)', 'gm')
const str = `12345678
87654321
3.123456
123456.3`;
const subst = `$1$2,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);