$re = '/([\s\S]*)(?=<div id="content")|(?=<div id="footer)([\s\S]*)/';
$str = 'hello this is some text I don\'t want
asdf
asdfasd
ff
<div id="content" class="other">
i have this other stuff
<div>More stuff</div>
<div id="footer>
hello^[^_]*_
asd;flkjasd
f;kas
dfas
df
asdf a2 5<div id="footer"><div id="content></div>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;