using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"name=""([^""]*?) 30 Minute Wait,";
string input = @"name=""Barnstormer, Fantasyland, 05 Minute Wait,name=""Big Thunder Mountain Railroad, Frontierland, 05 Minute Wait,name=""Celebrity Spotlight, Echo Lake, 05 Minute Wait,name=""DINOSAUR, DinoLand U.S.A., 05 Minute Wait,name=""Expedition Everest - Legend of the Forbidden Mountain, Asia, 05 Minute Wait,name=""Gran Fiesta Tour StarringThree Caballeros, World Showcase, 05 Minute Wait,name=""Great Movie Ride, Hollywood Boulevard, 05 Minute Wait,name=""Mad Tea Party, Fantasyland, 05 Minute Wait,name=""Meet Chewbacca at Star Wars Launch Bay, Animation Courtyard, 05 Minute Wait,name=""Seas with Nemo & Friends, Future World, 05 Minute Wait,name=""Star Wars Launch Bay Theater, Animation Courtyard, 05 Minute Wait,name=""TriceraTop Spin, DinoLand U.S.A., 05 Minute Wait,name=""Buzz Lightyear's Space Ranger Spin, Tomorrowland, 10 Minute Wait,name=""Dumbo the Flying Elephant, Fantasyland, 10 Minute Wait,name=""Encounter Kylo Ren at Star Wars Launch Bay, Animation Courtyard, 10 Minute Wait,name=""it's a small world, Fantasyland, 10 Minute Wait,name=""Kilimanjaro Safaris, Africa, 10 Minute Wait,name=""Magic Carpets of Aladdin, Adventureland, 10 Minute Wait,name=""Many Adventures of Winnie the Pooh, Fantasyland, 10 Minute Wait,name=""Mickey and Minnie Starring in Red Carpet Dreams, Commissary Lane, 10 Minute Wait,name=""Mickey's PhilharMagic, Fantasyland, 10 Minute Wait,name=""Muppet*Vision 3D, Muppet Courtyard, 10 Minute Wait,name=""Pirates of the Caribbean, Adventureland, 10 Minute Wait,name=""Primeval Whirl, DinoLand U.S.A., 10 Minute Wait,name=""Soarin', Future World, 10 Minute Wait,name=""Spaceship Earth, Future World, 10 Minute Wait,name=""Star Tours –Adventures Continue, Echo Lake, 10 Minute Wait,name=""Toy Story Mania!, Pixar Place, 10 Minute Wait,name=""Twilight Zone Tower of Terror™, Sunset Boulevard, 10 Minute Wait,name=""Under the Sea ~ Journey ofLittle Mermaid, Fantasyland, 10 Minute Wait,name=""Jungle Cruise, Adventureland, 15 Minute Wait,name=""Mission: SPACE, Future World, 15 Minute Wait,name=""Rock 'n' Roller Coaster Starring Aerosmith, Sunset Boulevard, 15 Minute Wait,name=""Splash Mountain, Frontierland, 15 Minute Wait,name=""Astro Orbiter, Tomorrowland, 20 Minute Wait,name=""Meet Disney Pals at the Epcot Character Spot, Future World, 20 Minute Wait,name=""Monsters, Inc. Laugh Floor, Tomorrowland, 20 Minute Wait,name=""Meet Rapunzel and Tiana at Princess Fairytale Hall, Fantasyland, 25 Minute Wait,name=""Space Mountain, Tomorrowland, 25 Minute Wait,name=""Enchanted Tales with Belle, Fantasyland, 30 Minute Wait,name=""Meet Cinderella and Elena at Princess Fairytale Hall, Fantasyland, 30 Minute Wait,name=""Meet Tinker Bell at Town Square Theater, Main Street, U.S.A., 30 Minute Wait,name=""Peter Pan's Flight, Fantasyland, 30 Minute Wait,name=""Test Track, Future World, 30 Minute Wait,name=""Meet Anna and Elsa at Royal Sommerhus, World Showcase, 40 Minute Wait,name=""Tomorrowland Speedway, Tomorrowland, 40 Minute Wait,name=""Frozen Ever After, World Showcase, 45 Minute Wait,name=""Meet Mickey Mouse at Town Square Theater, Main Street, U.S.A., 55 Minute Wait,name=""Meet Ariel at Her Grotto, Fantasyland, 65 Minute Wait,name=""Seven Dwarfs Mine Train, Fantasyland, 80 Minute Wait,name=""Haunted Mansion, Liberty Square, Temporarily Closed,name=""Kali River Rapids, Asia, Temporarily Closed
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}