// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-7][0-9A-HJKMNP-TV-Z]{25}").unwrap();
let string = "01G9HHNKWGBHCQX7VG3JKSZ055
01G9HHNTQY2E8HM5N9AE5SQBXQ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}