$re = '/\b(?!\d*(\d)\d*\1)\d+\b/m';
$str = '1234567890 987 787 544
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);